Diebstahlwarnanlage Restaurieren

  • Hallo,


    da mein Coupe zwar eine Diebstahlwarnanlage besitzt, diese aber seit Jahr und Tag nicht mehr funktioniert, wollte ich diese einmal restaurieren.

    Hat von euch jemand Erfahrungen damit? Wenn nicht, versuche ich einmal hier etwas Licht ins Dunkle zu bekommen. Scheinbar hat sich damit noch keiner so richtig beschäftigt.

    Es geht ja schon los, wo das Teil überhaupt genau sitzt ;-)

  • Hi,


    hab auch sowas, bei mir Funktioniert es und wird per Infrarot Fernbedienung aktiviert, hat dann die Sensoren allerdings hab ich es ausgeschaltet, da man manchmal per Infrarot den QP schlecht aufbekommt.


    Bei mir geht eine Fernbedienung nicht mehr von 2, bestimmt ist die Batterie Tot.
    Was echt cool wäre wenn man es von Infrarot auf Funk umrüsten könnte, aber dafür müsste man die alte Anlage rauswerfen und diese sitzt aber doch so schön im Handschuhfach ;)


    Du musst mal in deinem Handschuhfach Schauen ich meine Links im Eck (Handschuhfach) kannst du mit dem mini Schlüssel aktivieren und Deaktivieren, nicht das die bei dir einfach auf AUS steht.


    Grüße

  • Naja, das mit dem Schlüssel war mir schon bewusst. Das Problem liegt aber woanders.

    Die Anlage selbst sitzt hinter dem Kotflügel auf der Fahrerseite. Da kommt man so einfach nicht dran.

    Die Umrüstung sollte aber machbar sein, da der Infrarotempfänger nur einen Impuls ausgibt. Je nach Zustand des Fahrzeug, entscheidet dann die Elektronik dahinter ob auf oder zu geschlossen wird. Da ich das Coupe nur sehr selten aus der Garage hole, ist mir da die Originalität wichtiger als eine super Funktion. Alles was an Zubehör nachträglich mal hinein gekommen ist, fliegt gerade wieder raus. Es sei denn, es stammt aus der Zeit in der das Coupe verkauft wurde. Ich hätte eben gerne eine funktionierende Original Alarmanlage. Nicht weis diese so gut ist, sondern weil sie bei fast keinem 2.0 16V mehr funktioniert. Wenn mein Coupe schon kleine Klima hat ;-)

  • Ich habe auch noch so eine Alarmanlage, die mit einer runden Fernbedienung am Schlüssel geschaltet wird. Letztens war die Batterie kaputt und ich bekam das Ding kaum mehr aus. Sehr peinlich unterwegs auf einem Hotelparkplatz! Ich habe jetzt zwei neue Knopfzellen gekauft und die Batterien getauscht. Jetzt geht's wieder. Aber brauchen tue ich das eigentlich nicht. Ich habe nur die Angewohnheit, bei längerem Abstellen des Autos den Trennschalter zur Batterie im Motorraum zu unterbrechen, um eventuelle Kriechströme zu vermeiden. Wenn ich den dann wieder schließe, ist der Alarm aktiviert und ich brauche die Fernbedienung zum Abstellen. Ich finde das eher lästig.


    Gruß,

    Micha

  • Habe heute mal die Alarmanlage auf meinen Schreibtisch geholt.

    Wie zu erwarten sind die internen Akkus mausetot. Vielleicht ist das schon der Grund für die nicht funktionierende Alarmanlage.

    Ich werde mal versuchen die 26 Jahre alten NiCd Akkus mit meinem Prozessorladegerät zu reaktivieren.

    Leider findet man im Netz keine Erklärung zur Diagnoseschnittstelle der Anlage, geschweige denn eine Software.



    Hier ein paar Bilder:


  • Hallo,


    die Akkupacks sehen so aus, als wären es 4 eingeschrumpfte 3er Packs von CR2025 oder CR2032. Meinst Du nicht, es wäre gefahrlos möglich, die durch Eigenbauten zu ersetzen? Ansonsten vielleicht noch die Kondensatoren austauschen und mit der Lupe die Lötstellen prüfen. Viel mehr kann da eigentlich nicht kaputt gehen, wenn man in Betracht zieht, dass die Anlage wohl einfach so den Geist aufgegeben hat.


    Gruß


    Dirk

  • Viele Kondensatoren sind da nicht verbaut. Die Anlage ist intelligenter als man meint.

    Sie hat sogar eine Disgnoseschnittstelle für den Examiner, man kann sie ebenfalls programmieren.

    Die Akkus sind wirklich Akkus und keine Batterien. Man sollte sie also wenn gegen etwas gleichwertiges austauschen.

    Ich habe sie ein paar Tage und Nächte über den Tester gejagt und sie sind noch gut in Schuss.

    Es sind NiCD Akkus die man aber sicher auch gegen NiMH austauschen könnte. Wobei diese dann eine höhere Selbstentladung haben und frostempfindlich sind. Die verbauten Akkus haben 1,2V und 170mAh pro Zelle. Nach 5 mal Laden-Entland-Laden, hat der Tester 190mAh angezeigt. Sieht also ganz gut aus. Nach dem ersten Ladezyklus waren es nur 35mAh.

    Helfen würde natürlich die Diagnose, allerdings kann das wohl nicht mal mehr Fiat hier vor Ort...

  • Von den 2032 usw. gibt es ja auch Akkuversionen und die werden wohl auch in den Packs verbaut sein.. Ich kann mir schon vorstellen, dass es sich lohnen könnte, die Zellen auszutauschen. Nach 20-25(?) Jahren kann ich mir nicht vorstellen, dass bei der Regeneration viel rauskommt.

    Wenn ich das recht sehe sind es wirklich nur 6 Kondensatoren ... in dem Alter ist das umlöten aber schon fast eine Pflichtübung.

    Die Software ist offenbar nicht so das Problem: Link zu Software und der Adapter kostet auch nicht die Welt: Link zu Adapter


    Über allem steht halt immer die Frage, welchen Aufwand man betreiben möchte. Eine funktionierende Anlage kostet wohl auch nicht die Welt: Link zu Alarmanlage


    Und zum guten Schluss gibt es die Anlage ja auch in der (Link zu Lexikon) Barchetta: Link zum Forum Link zu Adapter


    Viele Grüße
    Dirk

    5 Mal editiert, zuletzt von dwbach ()

  • Du stellst dir das zu einfach vor.

    Zunächst einmal läuft die Softeware nicht ohne Lizenz bzw. Dongle.

    Der Titel dieses Threads heiß nicht "tausche Module" sondern "siehe oben".

    Es geht darum zu verstehen wie die Anlage funktioniert und was man daran "reparieren" muss, damit sie wieder funktioniert.

    Ob diese Teile bei eBay funktionierten weiß keine Sau und sie sind mit Sicherheit auch schon sehr alt.

    Als Pflicht sehe ich den Tausch von Kondensatoren auch nicht. Diese halten eigentlich recht lange außer in moderner Elektronik. Es werden keine hohen Temperaturen erreicht, sodass hier eigentlich keine Probleme auftreten sollten.

  • Moin,


    Ich habe zwar für unseren Dodge Appcar DiagFCA im Einsatz, aber zumindest zum Auslesen müsste, soweit mir bekannt, AlfaOBD, das zum Auslesen der baugleichen Anlage in der Barchetta genutzt wurde, auch ohne Lizenz laufen. Einen Adapter dürftest Du bei der Anlage wohl brauchen.

  • Naja, Adapter ist nicht das Problem. In der Barchetta steckt meines Wissens eine andere Alarmanalage. Genau wie in den Bj. ab 1996. Laut Schaltplänen ist das dann eine neuere und völlig andere Anlage. Ich habe im Barchetta Forum schon ein wenig gestöbert aber leider nichts brauchbares entdecken können bezüglich der Programmierung oder gar der Fehlerdiagnose per PC.

    Nur die Programmierung der Anlage ohne PC habe ich finden können.

  • So,


    alle Kondensatoren sind gewechselt und die Akkus sind aufgefrischt.

    Leider macht die Anlage immer noch nicht was wie soll.

    Da sganze gestaltet sich schwieriger als gedacht. Der Aufbau der Anlage ist ja doch nicht ganz so einfach, wie ich das anfangs vermutet hatte.

    Wir haben einmal die Alarmanlage mit Serene selbst welche im Kotflügel vorn auf der Beifahrerseite sitzt. Dann gibt es als Steuerung des ganzes Gebildes noch den IR Empfänger in der Innenraumleuchte. Dieser wertet die Signale der Fernbedienungen aus und gibt dann die Signale Öffnen und Schließen an das dafür vorgesehene Steuergerät der Zentralverriegelung weiter. Außerdem kommuniziert der Emfänger noch mit dem Alarmmodul per seriellem Eindrahtbus. Die Signale sind alle da, jedoch reagiert die Alarmanlage nicht. Zumindest kann ich jetzt die Eigendiagnose durchführen ohne das Fehler dabei heraus kommen.

    Zum Programmieren wird aber der 4 stellige Code benötigt, der auf einer der Fernbedieungen stand. Leider ist da nichts mehr zu lesen ;-(

    Auch komme ich im Moment nicht per Diagnose auf die Anlage. Das liegt vermutlich am falschen Interface. Das einzige was geht, ist das Motorsteuergerät. Das arbeitet ja mit K und L, die anderen nur mit K line. Ich lese jetzt erst einmal den EEPROM aus dem IR Empfänger aus, und schaue dann ob da etwas brauchbares zu finden ist bezüglich Code. In diversen Alfa Foren gibt es alte Beiträge die bezüglich. Leider antwortet da niemand mehr drauf.

  • Heute habe ich die Alarmanlage mal an den Examiner geklemmt.

    Scheint alles zu Funktionieren, bis auf die Verbindung zur Innenleuchte.

    Leitung unterbrochen oder defekt, wird als Fehler ausgeworfen.

    Jetzt ist die Frage, ob die wirklich defekt ist, oder bloß die Syncronisation der Codes nicht passt. Allerdings sollten die ja die gleiche sein, da am Fahrzeug nie etwas getauscht wurde.

  • 2 Jahre nach meiner Bastellei, bin ich leider noch keinen Schritt weiter.

    Es ist niemand aufzutreiben der die Anlage wieder zum laufen bringt.

    Problem ist, wie damals schon geschrieben die Syncronisierung zwischen Fernbedienung , Alarmanalage und Motorsteuerung.

    Leider sind sämtliche Codes nicht mehr auffindbar. Zum Programmieren neuer Handsender muss der Installationscode zur Hand sein.

    Diesen gab es wohl mit dem Schlüssel als kleinen Pappanhänger beim Kauf dazu in Original.

    Fiat scheint keine Möglichkeit mehr zu haben, diesen Code im Nachhinein zu besorgen.

    Auch der Examiner möchte den Code auf jeden Fall haben um Änderungen durchführen zu können.



    Zumindest bin ich etwas weiter gekommen, was den Aufbau angeht.

    Die Handsender werden im IR Empfänger in der Innenlampe gespeichert. Dieser Empfänger besitzt 2 Kabel zur Steuerung der Zentralverriegelung und eine serielle Leitung zur Alarmanlage. Diese wiederum hat eine serielle Leitung zum Motorsteuergerät für die Wegfahrsperre. Passt eines der Codierungen nicht zum anderen, versagt es seinen Dienst.